The CloudLinux PHP Selector

All of our cPanel Servers are running CloudLinux cPanel/WHM.

PHP Selector is a CloudLinux component that sits on top of CageFS.

It allows each user to select PHP version & module based on their needs.

You can easily switch between several different PHP Versions, as well as enable or disable many PHP modules, such as apc, mysqli, gd, pdo, soap and etc. entirely based on your needs.

Here is how to do that:

1) Login to the cPanel Account:

Login to the cPanel Account

2) Navigate to the Find tab and search for: php



3) Click on the Select PHP Version icon, under Software and Services:



4) You should be looking at the current PHP Configuration, which be the default is the "native (5.5)" - the default PHP Version and modules enabled on the Server:



5) In order to be able to change the PHP Version or to enable PHP modules, you have to change the PHP Version first. Select 5.5 for example:



6) Now click on Set as current and enable some PHP modules if you need them.

To complete the change, click on the Save button at the bottom.

7) If you want to change the PHP Settings such as: max_execution_time, upload_max_filesize, memory_limit and etc., click on Switch to PHP Settings:



8) Make the needed changes by clicking on their Value:



max_execution_time:






upload_max_filesize:



Finally, click on Save to save the PHP Settngs.

Was this answer helpful?

 Print this Article

Also Read